Loading...

BADGER

 

Please ensure you have completed the requirements before downloading and registering.

  • The Badger LMS software requires Java Runtime Environment (JRE) to be installed on your machine. Please download and install the appropriate file for your operating system. If you have problems installing Java, please contact the IT Helpdesk.

 

 

For more information, please click here